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PRACOVNÍ PLOCHA 
 

Základním dialogovým oknem pragramu Origin je pracovní plocha s mnoha okny k provádění rozličných 

úprav. Nejprve se vždy automaticky otevře pracovní sešit pojmenovaný Book 1. 

 

 

1) Volba nové pracovní plochy workbook 

se provede: File:→New→Workbook→OK (Book2) případně pomocí ikony New Workbook . Druhá 

otevíraná pracovní plocha se automaticky označí jako Book 2. 

 
 

Přejmenování otevřené pracovní plochy Book 1 novým  názvem se provede příkazem: Book 1 (klik) →pravou  

myší→Properties→ do Long name napíšeme nový název. 
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2) Otevření Excelovského souboru se provede: File→New→Excel→OK nebo 

ikonou New Excel  (otevře se okno excelu vždy ve verzi, která je nainstalována) 

 
 

3) Otevřít okno grafu se provede: File→ New→ Graph→OK (Graph1) nebo také kliknutím na 

ikonu  New graph  . 
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4) Otevřít okno matice se provede příkazem: File→New→Matrix→OK (MBook1) nebo 

kliknutím na ikonu  

 
 

5) Otevřít okno funkce se provede příkazem: File→New→Function→OK (Plot Details; se 

záložkou function) nebo pomocí ikony  
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6) Otevřít okno plochy návrhu (Layout) 

se provede příkazem: File→New→Layout→OK (prázdné okno) nebo pomocí ikony ; do plochy návrhu si 

píšeme své poznámky, v šedivé oblasti plochy návrhu lze pravou myší rolovat formát stránky třeba 

z pohlednice na portrét a naopak. 

 
 

7) Otevřít plochu okna poznámky (notes), čili sdělení, vysvětlivek, glosy, 

anotace se provede příkazem: File→New→Notes→OK nebo pomocí ikony  
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8) Otevřít plochu okna Results Log (výsledků) se provede příkazem: 

View→ Results Log nebo zkráceně klávesovou zkratkou Alt+2, stejně lze také i zavřít nebo lze použít ikonu 

 

 
 

9) Otevřít Script okno se provede příkazem: Window→ Script Window nebo Alt+3 nebo 

View→Script Window  

 
 

10)  Otevřít Code builder- vývojové prostředí k programování se 

provede příkazem: View→ Code Builder nebo Alt+4 anebo použijete ikonu  
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SPECIFICKÉ MENU 
Potřebné specifické menu, které odpovídá charakteru dotyčné pracovní plochy. Pokud máme otevřený 

Workbook, vidíme jiné menu než když jsme v okně grafu. 

 

1.) Specifické menu pro nový projekt otevřeme příkazem: File→ New→ Project→ OK. 

 
 

2.) Specifické menu pro nový graf otevřeme příkazem: File→ New→ Graph →OK. 

 
 

3.) Specifické menu pro novou matici otevřeme příkazem: File→ New→ Matrix→ OK. 

 
 

4.) Specifické menu pro novou excelovskou plochu otevřeme příkazem: File→ New→ Excel→OK. 

 
 

 

Toolbars (panely nástrojů) 
Potřebné panely nástrojů otevřeme následovně: 

1.) Otevřít a zavřít panely nástrojů se provede příkazem: View→ Toolbars otevře se dialogové okno 

Customize Toolbar a zaškrtneme okénka, která chceme zobrazit. 

 

Projektový průzkumník (Project Explorer): 

Uvedeme několik vhodných základních operací, které provádíme v projektovém průzkumníkovi a které je 

třeba ovládat: 

1.) Zobrazení plochy průzkumníka se provede příkazem: File→ New→ Project (průzkumník se objeví jako 

spodní lišta nebo přes ikonu  nebo klávesovou zkratkou Alt+1. 

 
 

2.) Přidání dalších pracovních ploch čili workbooků provedeme ikonou . 

3.) Přidání podadresářů (subfolders) se provede příkazem: Pravou myší klikneme na ikonu Untitled  v levém 

okně průzkumníka, vybereme možnost New Folder, který se nám otevře v pravém panelu průzkumníka. Takto 

vytvořená složka se dá přejmenovat pravým tlačítkem myši a volbou Rename. Poté zamodříme všechny grafy 

a tažením myši přesuneme do složky grafy, podobně pak data atd. 

 
 

4.) Uložení podadresářů jako samostatných souborů se provede příkazem: v levém okně klikneme na složku 

Graphs a pravou myší pak vybereme Save as Project, pojmenujeme grafy.opj a ukončíme uložením. 
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5.) Skrývání a odkrývání průzkumníka se provede příkazem: nejlépe ikonou .  

6.) Přepnutí průzkumníka z lišty na samostatné dialogové okno se provede dvojklikem na vertikální dvojčáru 

v levé oblasti: 

 
 

PRACOVNÍ LISTY, IMPORT DAT A VYNESENÍ 

GRAFŮ 
 

1) Import výběru dat pomocí průvodce Wizard: 

a. Klikneme na ikonku New Project . 

b. V menu zvolíme File→ Import→ Import Wizard. 

c. V oblasti označené Data Source u okénkové volby File klikneme na ikonu  při pravém okraji a pak a 

vybereme požadovaný soubor, např. Origin/tutorial/tutorial_1.dat. 

d. V roletce Import Filters for Current Data Type zvolíme <none> a klikneme dole na pokračovací 

políčko Next >>. 

 
 

e. Další dialog necháme nezměněný a pokračujeme Next >>. 

f. Vyplníme počty řádků a sloupců v hlavičce následovně: 

i. Do Number of Subheader Lines dáme 2. 

ii. Do Short Names dáme 0. 

iii. Do Long Names dáme 1. 

iv. Do Units dáme 2. 
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g. Klikneme dole na pokračovací tlačítko  a zobrazí se nám vybraná data takto: 

 
 

2) Zadání sloupců tabulky pracovní plochy 

Při tvorbě grafu chápe Origin vždy první nalevo umístěný sloupec jako x-ový a všechny sloupce od něj 

doprava jako y-nové:  

a. Umístíme kurzor na hlavičku sloupce Error1(Y) a dvojklikneme levou myší. Otevře se okno Column 

Properties. 

b. Na záložce Properties v bloku Options a v okénku Plot Destination nalistujeme a zařadíme YError. 

c. Klikneme nahoře na pokračovací políčko Next>>. 

d. Kurzorem podobně zvolíme sloupec Test2 jako Y-osu a opět klikneme na Next>>. 

e. Abychom zavolili sloupec Error2 jako za chybový sloupec, nalistujeme YError v okénku Plot 

Destination v bloku Options. 

f. Kurzorem podobně zavolíme sloupec Test3 jako Y-osu a opět klikneme na Next>> a zvolíme Error3 

jako jsme provedli předešle. 

g. Ukončíme kliknutím na OK.  



ZÁKLADNÍ KURZ PROGRAMU ORIGIN 8.5  ING. ZUZANA FERENČÍKOVÁ 

 

10 
 

 
 

 

Vynesení grafu: tvorba 2D a 3D grafů je snadná a provede se vždy ve dvou krocích. V prvním 

kroku zvolíme data, v druhém kroku vytvoříme graf pomocí vhodné ikony. Postup je následující: 

a) Kurzorem najedeme do levého horního rohu tabulky tak, aby se objevila šipka, čímž aktivujeme celou 

tabulku takto: 

 

b) Klikneme na ikonu Line+Symbol ,která se nachází na spodní liště obrazovky… 
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c) …a získáme tento graf. 

 
 

3) Zoomování detailní výřez pouhé části grafu  

Kliknutím na ikonu lupy (toolbar vlevo)  vybereme oblast, kterou chceme detailně zoomovat. 
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a takto dostaneme zvětšenou část. 

 

Pokud chceme graf zpět zmenšit, použijeme podobně ikonu  a graf se vrátí do původní velikosti. 

 

4) Přizpůsobení vzhledu skupinového grafu, což znamená grafu, ve kterém 

jsou body spojeny do skupiny:  

a) Dvojklikem na body se otevře okno Plot Details, ve kterém lze vlastnosti grafu přenastavit. V levé 

polovině okna je hierarchie primárních prvků grafu: Graph→Layer(s) →Data Set(s). V pravé polovině okna 

Plot Details je konkrétní nabídka nastavení čar (Line), symbolů (Symbols), přívodních průvodičů bodů 

k osám (Drop Lines) a také upravení vlastností skupiny bodů (Group). 

 
 

b) V záložce Line lze měnit způsob proložení bodů (connect), styl čáry, její šířka, barva a je zde také 

možnost vyplnění plochy pod křivkou. 

c) V záložce Symbol lze měnit velikost, styl, barva, šířka čáry u symbolů. 

d) V záložce Drop Lines lze zvolit přívodní linky bodů k osám. 

e) V záložce Group lze měnit závislost dat, tedy jestli tvoří skupinu nebo jsou to individua. Pokud máte více 

čar (tedy třeba 3 měření), lze jim nastavit Dependent, tzn. že tvoří skupinu a pak budou mít všechny čáry i 

body stejné vlastnosti (nemusí být nutně barevné, to lze změnit pomocí políčka Line Color viz dále). Pokud 

nastavíme Independent, lze každé čáře přiřadit jiné vlastnosti. 
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5) Úprava os grafu: 
a) Dvojklikem na osu x se otevře dialog X Axis-Layer 1. 

b) V záložce Tick Labels lze vybrat typ osy (numerický, datum…), „jednotky“ (decimal, engineering, 

specific), font písma, barva, velikost bodů. 

c) V záložce Minor Tick Labels nastavujeme zobrazení hlavních označení (Minor Tick) 

 
d) V záložce Custom Tick Labels lze nastavit rotaci označení, případně vynechání zvolené hodnoty na ose 

apod. (pouze pro pokročilé uživatele). 

e) V záložce Scale lze měnit zobrazovanou oblast nastavením nových hodnot From a To a také krok, po 

kterém se budou zobrazovat označení, Increment např. po 1 jednotce. 

f) V záložce Title & Format lze nastavit název osy, její barvu, sílu čáry, délku hlavních označení a 

orientaci hlavního i vedlejšího označení (ven, dovnitř, ven i dovnitř nebo bez označení). 

g) V záložce Grid Lines lze zvolit zobrazení pomocných čar rastru. 

h) V záložce Break lze nastavit přerušení osy. 

V každé záložce se nalevo zobrazuje Selection, kde si můžeme vybrat, kterou osu chcete upravovat. Lze tak 

upravovat současně všechny osy v jednom okně. 

6) Legenda a nadpis grafu: 
a) Legenda se dá volně přesouvat po kliknutí na ni. Pokud se stane, že legendu smažeme, dá se znovu 

vyvolat tlačítkem  nebo klávesovou zkratkou Ctrl+L. 

b) Nadpis i jiné popisky ke grafu lze přidat kliknutím na ikonu , poté klik na místo, kam ji chceme 

umístit a následné napsání textu. Opravit lze vše pomocí pravého tlačítka myši a výběr Properties, kdy lze 

nastavit i velikost textu, barva, písmo. 

 

7) Uložení grafu: Kliknutí na ikonu  nebo kliknutím na File→ Save project As. 

 

IMPORT DAT POMOCÍ WIZARDA 
 

Načte se ASCII datový soubor metodou importu wizarda, načte se také informace z hlavičky ASCII souboru 

k vytvoření popisu os grafu: 

 

1) Volba souboru k importu ve Import Wizard- Source:  

Klikneme na ikonu New Project  ze standardního menu nástrojů, a pak File→ Import→ Import 

Wizard→ otevře se nám dialog Import Wizard Source→ v Data Type označíme ASCII→ v Data Source 

vyhledáme soubor pomocí tlačítka →Tutorial_ASCII.dat z knihovny tutorial→ v oddílu Import Filter u 

výběru Import Filtres for current Data type zvolíme <none>→ Next>>. 
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2) Volba tvaru názvu 
V dalším dialogovém okně si zvolíme, jak se má zobrazovat popis souboru. V nabídce Rename zašktneme 

volbu worksheet with filename a volbu workbook with a file name 

 
 

3) Přizpůsobení importu pomocí Import Wizard- Header 

Lines: 
Jde zde o vyplnění a nastavení řádků hlavičky Wizardu. Obsahují možnost volby nastavení hlavičkových 

řádků jak interpretovat data. Nastavuje se defaultní šablona formátu dat, kterou lze změnit na začátku každé 

stránky: 

a) Počet hlavičkových řádků (Nr. Of Main Header lines) = 6 (většinou řádky obsahující popis procedury) 

 Počet podřádků (Nr. Of Subheader Lines) = 2 (počet řádků obsahujících název, jednotky, komentáře aj.) 

 Short Names = 0 (zkrácený název, není nutný). 

 Long Names = 1(název měřené veličiny) 

 Units = 2 (jednotky měřené veličiny) 

 Comments = None (komentáře, pokud jsou obsaženy) 

 System parameters = None (systémové parametry, pokud jsou obsaženy) 
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 User parameters = None (parametry uživatele, pokud jsou obsaženy, např. teplota, data, která znáte, ale 

nepotřebujete jejich hodnoty v grafické podobě) 

Ukáže se barevný náhled hlavičky k osobní kontrole, zda zadání řádků je správné.  

 
 

b) Klikneme na Next>>. 

c) Další dialog necháme nezměněný. Pokračujeme pomocí Finish. 

 

4) Uložení nastavení jako filtru v Import Wizard- Save Filtres: 
Pokud budeme načítat stále stejně uložená data, můžeme si uložit nastavení filtru. V předchozím příkladě 

bychom toho dosáhli tak, že místo Finish v kroku c) budeme pokračovat pomocí 3 x Next>> až se dostaneme 

do dialogu Save Filters. 

Zaškrtneme okénko Save Filter→ zapneme v okénku In The User Files Folder→ Filter file name (.OIF) se 

zadá jméno filtru např. Tutorial → v okénku Specify data file names to which… se napíše 

JMENOFILTRU*.DAT čili např. Tutorial.dat→ volba Specify advanced filter option se nechá nezaškrtnutá a 

klikneme na Finish. 
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5) Využití hlavičky dat k vytvoření uživatelského štítku (popisu). 

Nyní, když máme data importovaná, můžeme si ukázat užitečnost hlavičky souboru ASCII. Vytvoříme graf a 

nadpis a k popisu grafu využijeme hlavičku z ASCII souboru: 

a) Aktivujeme všechny buňky tabulky umístěním šipky do levého horního rohu tabulky. 

b) Zvolíme Plot→ Panel→ Stack, čímž se nám vytvoří čtyři grafy pod sebou čili říkáme vznikl graf o 

čtyřech vrstvách. 

c) Klikneme na panel  a pak do horního řádku grafu umístíme nadpis, např. response of the Human Ear 

……, a to tak, že stiskneme Ctrl+H a využijeme nabídnuté věty nadpisu. Otevře se okno Insert Variables. 

Vybereme File1 tím, že klikneme na + před popisem, najdeme Header, označíme tento → zvolíme Insert a 

Close. 
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6) Využití importního filtru: naimportujeme stejná data za použití předešlého filtru. 

a) Klikneme na ikonu New projekt , čímž vytvoříme nový projekt. 

b) Provedeme File→ Import→ Import Wizard. 

c) Opět vybereme pomocí ikony  soubor TutorialASCII.dat→ Open. 

d) Označíme okénko List Files Applicable to Both Data Type and File Name. 

e) Z Import Filtres For Data Type vybereme nabídku User:Tutorial. 

f) Dokončíme pomocí tlačítka Finish. 
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NASTAVENÍ VZHLEDU GRAFU 

Tvorba nového grafu 

a) Otevřeme Nový projekt ikonou  nebo File→ Open→ Tutorial/ Tutorial_Plot_ Setup.OPJ. 

b) V menu vybereme Plot: → Template library, což otevře okno Template Library. 

c) V seznamu bloku Category vybereme Multicurve 

d) V seznamu bloku Multicurve vybereme Double Y a vpravo umístěné okno Preview ukáže dvojitou Y-

osu čili graf o dvou Y osách. 

e) Klikneme na Plot a otevře se trojokno Plot Setup (pokud je to pouze dvojokno či ještě méně, klikneme 

na  pro zobrazení dalšího panelu celého trojokna). 

f) V nejvýše umístěném horním okně panelu zamodříme Data1 a v okně Available Data: zvolíme volbu 

Current Worksheet. 

 
 

g) V dolním nejnižším panelu vidíme dvě vrstvy, každá z nich odpovídá jedné ose Y v grafu, který jsme 

právě otevřeli. Klikneme na vrstvu Layer1 a zamodříme ji. Tuto vrstvu nyní „naplníme“ daty.

 
 

h) Přeneseme se do prostředního panelu, vybereme zaškrtnutím okénko ve sloupci X a v řádku, který 

obsahuje proměnnou Time ve sloupci Column. Vybereme nyní zaškrtnutím okénko ve sloupci Y a na řádku, 

který má jako sloupcové návěští STPotencial.  Pak klikneme na Add a vložíme tento datový graf do vrstvy 

Layer 1.  

 
 

i) V dolním panelu aktivujeme zamodřením Layer2. 

j) Ve středním okně ve sloupci Y změníme zaškrtnutím okénko řádku se sloupcovým návěštím 

SVPotencial. Pak klikneme na Add a vložíme tento nový datový graf do vrstvy Layer 2. 

k) U obou vrstev (Layer1 i Layer2) zaškrtneme Rescale a dokončíme graf pomocí OK. To uzavře 

dialogové okno a vytvoří nový graf se dvěma osami Y. Popis os se tvoří automaticky dle řádku Long Name 

uvedeného ve Workbooku a jednotky se přiřadí dle řádku Unit uvedeného ve Workbooku. 
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Editace existujícího grafu 
Slouží k úpravě existujícího grafu.  

a) Pokud nemáme okno s grafem aktivní, aktivujeme graf příkazem Window→ Graph 1. 

b) Dvojklik na ikonu s číslicí 1 nebo 2 v levém horním okně grafu otevře trojokno k nastavení grafu Plot 

Setup: Configure Data Plots in Layer. 

c) V dolním nejnižším panelu Plot Setup zamodříme v sekci Layer2  řádek s proměnnými, Time(X) a 

SVPotencial(Y), čímž se aktivuje nastavení v prostředním okně panelu. 

d) Zde změníme Y na STPressure za název sloupce a pak klikneme na Replace. Tím se změní datový graf 

ve vrstvě Layer 2 za nový graf, jak je zadáno v prostředním panelu. 

e) U Layer2 opět zaškrtneme Rescale a potvrdíme změnu v nakreslení pomoci OK. 

 
 

Graf z více pracovních sešitů čili z více workbooků: 
(jde například o reprodukovaná měření). Naučíme se, jak vytvořit nový graf z více úloh čili z více workbooků: 

a) Pomocí volby Window vybereme jakákoliv data z předchozí úlohy (Data1, Data2 nebo Data3). 

b) Na horní liště menu vybereme Plot→ MultiCurve→ Vertical 2 Panel a opět se nám otevře dialog Plot 

Setup: Select Data to Create New Plot a nyní se nastaví celý graf. Nejprve se musíme ubezpečit, že všechny 

tři panely jsou otevřené. 

c) Vlevo nahoře ve výběru Available Data vybereme možnost Worksheets in Folder, čímž se nám vpravo 

zobrazí všechny tři pracovní listy. Přepínáním mezi nimi se automaticky změní nastavení ve středním okně. 
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d) Když jsme vybrali všechny tři worksheety v horním panelu, prostřední panel zobrazí všechny sloupce, 

které jsou společné těmto třem worksheetům. V této úloze mají všechny tři worksheety stejné sloupce a budou 

proto všechny sloupce zobrazeny. 

e) Ve středním okně bude společná předvolba os a zvolíme za X proměnnou Time a za Y proměnnou 

zvolíme STPotential. 

f) Přesvědčíme se, že v dolním okně je zvolena Layer1 a pak klikneme na Add. Všechny tři grafy jsou 

zařazeny do této vrstvy jako skupina (Group), tzn. při změně vlastností jednoho z nich se změní všechny.  

g) V dolním okkně zamodříme  Layer2, ve středním okně vybereme za Y na proměnnou STPressure a 

klikneme na Add, a tím dáme všechny tři datové grafy do Layer 2.  

h) Zapneme u obou Rescale a vytvoříme graf pomocí OK. 
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PRÁCE S EXCELEM V ORIGINU 
 

Pracovní sešit z Excelu lze přímo otevřít v Originu. To dovoluje kombinovat všechny excelovské nástroje 

s originovskou tvorbou grafů a analytických nástrojů.  

 

Otevření excelovského souboru: 

a) Klikneme na ikonu New Project   

b) Výběr souboru provedeme pomocí File→ Open excel→ Tutorial_7.xls→ OK 

c) Otevře se nám okno Excelu (verze, jež je nainstalována v počítači), můžeme tedy využívat výhod obou 

programů, jak Excelu, tak Originu. 

 

Tvorba grafů z Excelovského sešitu: 
Tvorba grafů z excelovského sešitu je velmi podobná tvorbě grafů z originovského souboru. Můžete 

jednoduše označit data a pomocí ikonek či lišty nástrojů vytvořit graf dle svého přání. 

 

Tvorba grafu pouze z vybraných dat: 

a)  Klikneme na ikonu sloupcového grafu Column  na nástrojové liště 2D grafu→ otevře se dialog 

Select Data for Plotting. 

b)  Přemístíme tento dialog tak, abychom viděli na data v tabulce. 

c) V okně s daty klikneme na sloupec A a v dialogu klikneme na , čímž se sloupec A přiřadí k ose X. 

d)  V okně s daty klikneme na sloupec C→ držíme Ctrl a klikneme na sloupec F→ v dialogu klikneme na 

, čímž se tyto dva sloupce přiřadí k ose Y. 

 
 

e)  Klikneme na Plot a poté Close a dostaneme graf s vybranými daty. 

f) Přesuneme legendu grafu na střed pomocí označení myší a tažením na vybrané místo. 
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g)  Pokud se nad grafem objeví široká šedá část Toolbar Spacer, lze ji odstranit pravým tlačítkem myši a 

výběrem Hide Toolbar Spacer. 

 

Vytvoření grafu přímým přesunem (dragováním) dat:  

Pokud budeme přesouvat excelovská data na originovský graf, Origin se sám vytvoří předpoklady pro 

zobrazování v zobrazovacích vzdálenostech:  

a) Pokud je prosvícením vybrán pouze jeden sloupec, pak je tento sloupec brán jako Y a data se zobrazují 

v závislosti na pořadovém čísle a vznikne indexový graf. 

b) Pokud bude vybrán víc než jeden sloupec, pak za X se bude brát sloupec umístěný nejvíce vlevo, ostatní 

sloupce pak budou Y. Data budou vynesena proti X. 

c) Pokud je prosvícením označen víc než jeden sloupec nebo celá matice a během přesunu dat se podrží 

Crtl, pak budou všechna vybraná data označena jako Y. Data se zobrazí opět v závislosti na pořadovém čísle a 

vznikne indexový graf. 

 

Pro tvorbu grafu přímým přesunem postupujeme takto: 

a) Klikneme na ikonu New Graph , čímž se nám otevře prázdný graf, kde budou pouze osy. 

b) Zmenšíme okno grafu tak, abychom viděli i na excelovská data. 

c) Z dat vybereme první dva sloupce→ pohybujeme pomalu myší na okraj výběru dokud se nezmění na 

nebo na  

d) Uchytíme pravou hranu výběru a táhneme až do okna grafu. 

e) Jakmile pustíme tlačítko myši, vynese se sloupec B proti sloupci A 
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Vytvoření grafu pomocí defaultního nastavení Originu  

Umožňuje vybrat data a typ grafu, který Origin sám automaticky vytvoří. Tato metoda není defaultně 

nastavená, je nutné ji aktivovat pomocí Window (musí být aktivní okno s daty)→ Origin Options→ záložka 

Excel→ zaškrtnout Dafault Plot Assignament→ OK→ No. 

a) Aktivujeme Excelovská data. 

b) Pomocí Ctrl označíme prosvícením sloupce A, D a G, čili Ctrl+A, Ctrl+D a Ctrl+G. 

c) Klikneme na ikonu Area   v menu Plot nebo na nástrojové liště 2D grafů 

d) Přesuneme legendu grafu tažením myší. 

 
 

 

Uložení Excelovského sešitu v Originu  

Existují dva způsoby uložení excelovského souboru: 

a) Uložení jako interní soubor, který je součástí projektu Origin a lze otevřít pouze v Originu. Hlavní 

výhodou tohoto uložení je, že všechny grafy, analýzy atd. se ukládají společně do jednoho souboru. To 

usnadňuje sdílení dat s jinými uživateli Originu.   

 Pro uložení souboru jako interního postupujeme takto: Aktivujeme okno s excelovskými daty → 

klikneme pravým tlačítkem myši do názvu okna→ Properties→ Save As vybereme Internal→ OK.  
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 Nakonec File→ Save Project As→ pojmenujeme jako Excel_Tutorial→ Uložit 

 
b) Uložení jako externí soubor. Pokud zvolíme toto uložení, odkaz na sešit je uložen v souboru projektu. 

 

VYŠETŘENÍ DAT 
 

Origin nabízí řadu nástrojů k vyšetření a analýze dat jako je třeba Data Reader, Data Selector, Screen 

Reader, zvětšování (zoom) a různé nástroje pro maskování dat z Mask Toolbar. 

 

Import dat ve formátu ASCII 

Data importujeme příkazovými ikonami New Project → Import ASCII → Tutorial_2.Dat→ Open. 

 

Data Reader 

a) V datech označíme prosvícením sloupec Time(Y) a klineme na ikonu Line+Symbol graf  

b) Dostaneme graf 
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c) Pro zjištění hodnot X a Y vybraného bodu klineme na nástrojové liště na ikonu Data Reader  → otevře 

se nám dialog Data Display a změní se nám vzhled myši na zaměřovací rámeček 

d) Vybereme si bod, jehož souřadnice chceme znát a klikneme na něj levým tlačítkem myši 

e) V dialogu Data Display se nám zobrazí souřadnice vybraného bodu. Pokud chceme zvětšit křížek 

označující vybraný bod, zmáčkneme mezerník a křížek se zvětší (můžeme několikrát opakovat) 

f) Pokud již nepotřebujeme tento nástroj, vybereme z nástrojové lišty jiný nebo použijeme klávesu Esc 

 
 

Screen Reader 
Tento nástroj slouží k určení souřadnic jakéhokoliv bodu v okně grafu, např. vybraného bodu na křivce nebo i 

bodu v prostoru mimo křivku. 

a) Aktivujeme okno Graph1 

b) Z nástrojové lišty klikneme na ikonu Screen Reader  a otevře se nám opět dialog Data Display 

c) Nyní klikneme na křivku mezi dvěma libovolnými body a v dialogu Data Display se nám opět zobrazí 

souřadnice tohoto bodu 

 
d) Pokud již nepotřebujeme tento nástroj, vybereme z nástrojové lišty jiný nebo použijeme klávesu Esc 
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Data Selector 
Tento nástroj slouží pro výběr dat přímo z grafu, se kterými se dále pracuje. Např. pokud máme kalibrační 

křivku, která se nám na konci začíná ohýbat (tedy již není lineární), můžeme vybrat jen ty body, které jsou 

lineární a ty proložit přímkou. 

a) Aktivujeme okno Graph1 

b) Na nástrojové liště klikneme na ikonu Data Selector , čímž se nám v grafu označí první a poslední bod 

 
c) Pro změnu prvního nebo posledního bodu řady posuneme označení tažením na jiný bod nebo použijeme 

Crtl+ šipku doprava či doleva. Pokud použijeme Ctrl+Shift+ šipku doprava či doleva, posuneme se nám 

ukazatel o 5 bodů. 

d) Posuneme první bod k 4. bodu shora a poslední bod k 3. bodu zdola 

 
e) Nyní z menu zvolíme Analysis→ Fitting→ Linear Fit→ Open Dialog→ OK a proloží se nám jen body 

ohraničené námi vybraným prvním a posledním bodem 
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f) Pokud již nepotřebujeme tento nástroj, vybereme z nástrojové lišty jiný nebo použijeme klávesu Esc 

Pozn: Pod číslem 1 (označení vrstvy) se nyní objevil malý zelený zámeček. Pokud je tento zámeček zelený, 

znamená to, že jsou užita nejnovější data. Pokud se jeho barva změní na žlutou, znamená to, že je potřeba 

update dat (např. pokud vybereme jinou oblast dat). Pokud chceme, aby se proložení přepočítávalo 

automaticky při každé změně dat, klikneme levým tlačítkem myši na zámeček a v rozbalené nabídce zvolíme 

Recalculate Mode:Auto (dvě čárky v zámečku se změní na šipku). 

 

 

Zvětšení a výřezy grafu 
Nástroj lupa nabízí kromě zvětšení vybrané části grafu také výřez a jeho zobrazení v samostatném okně. 

Pokud potřebujeme pouze detail grafu, klikneme na ikonu Zoom In  a označíme vybranou část grafu. 

Stane- li se, že vyberete nevhodnou část a potřebujete se vrátit k původní velikosti grafu, jednoduše klikneme 

na ikonu Zoom Out  a graf se zobrazí v původní velikosti. 

Pro zobrazení vybrané části grafu (výřez) v jiném okně, stačí během označování podržet klávesu Ctrl. 

Budeme- li chtít změnit oblast výřezu, jednoduše posuneme výřez v původním okně na novou oblast a ta se 

nám následně zobrazí zvětšená. Velikost výřezu lze upravit pomocí zvětšení či zmenšení výběru. 
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Pokud chceme výřez zobrazit ve stejném okně jako původní graf, musíme si nejdříve přidat rozšířenou 

nástrojovou lištu 2D grafů a to tak, že z menu vybereme View→ Toolbars a zaškrtneme navíc volbu 2D 

graphs Extended. Poté aktivujeme okno s daty, vybereme sloupec Time(Y) a klikneme na ikonu Zoom . 

Zobrazí se nám graf o dvou vrstvách. Změnu výřezu provedeme opět posunem výřezu levým tlačítkem myši 

v horním grafu. 

 
 

Transformace sloupcových hodnot 
V dialogovém okně Set Column Values (otevře se označením sloupce→ pravé tlačítko myši→ Set Column 

Values) můžeme vytvořit nebo transformovat data pomocí matematických vzorců. Toto dialogové okno 

obsahuje textové pole pro vlastní zadání hodnoty nebo matematického výrazu pro transformaci celého sloupce 

nebo jeho části. Tento blok obsahuje nabídku funkcí a seznam sloupců, ze kterých můžeme vybírat a pak 

funkci přidat po kliknutí na Add Function. Dále zde je seznam všech sloupců, ze kterých budeme vybírat a 

pak sloupec přidat kliknutím na Add Column. Textové pole lze ovšem také využít pro transformaci dat 

z jiného pracovního listu do libovolného sloupce aktuálního listu, např. col(A)=DATA1_b*3 

 

Transformace dat: 

 Nejprve vložíme nový sloupec do aktuálního listu a to tak, že klikneme na sloupec Depth(Y) (to znamená 

C(Y))→ pravé tlačítko myši→ Insert, čímž nám vznikl prázdný sloupec N1(Y).  

 Dvojklikem na nový sloupec se otevře dialog Worksheet column Format, kde změníme Long Name na 

TimeMin→ OK. 
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 Klikneme pravým tlačítkem myši na tento sloupec N1(Y)→ Set Column Values→ do textového pole 

napíšeme col(B)/60→ zvolíme Recalculate a vybereme Auto→OK.  

 Volba Auto umožňuje automatické opravy hodnot, pokud se změní hodnoty ve zdrojovém sloupci. Pokud 

je tato volba aktivní, u popisu sloupce se nachází zámeček . 

 Pravým tlačítkem klikneme na sloupec B(Y)→ Set Column Values→ do textového pole napíšeme 

col(B)+100→ OK. 

 Tím se změnily hodnoty nejen ve sloupci B(Y), ale díky Auto Recalculate také ve sloupci N1(Y). 

 
 

 

Třídění dat v pracovním sešitě 
Origin umí třídit data v jenom sloupci, více sloupcích či celém pracovním listě, a to sestupně či vzestupně: 

a) Držením Ctrl vybereme všechny sloupce kromě TimeMin(Y), jehož hodnoty jsou závislé na hodnotách 

v jiném sloupci. 

 

b) Klikneme na ikonu Sort  na toolbaru (pokud už není k dispozici v menu, aktivujeme ji pomocí 

View→ Toolbars→ zaškrtneme Worksheet data) nebo Worksheet→Sort Colums→Custom. 

c) Vybereme Depth→   a STN→  →OK 
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Vynesení pouze části dat do grafu 
a) Pravým tlačítkem klikneme na prázdný obdelník v levém horním rohu Workbooku→ Go To → do 

okénka Row napíšeme požadované číslo řádku 52→ OK. 

b) Klikneme na řádek 52→ pravé tlačítko myši→ Set As Begin. 

c) Přesuneme se na bod č. 68 a klikneme na řádek 68→ pravé tlačítko myši→ Set As End. 

d) Ostatní data byla zakryta, jejich obnovení či restaurování  provedeme pomocí aktivace celého listu tak, že 

dáme šipku do levého horního rohu→ Edit→ Reset To Full Range. 

e) Za současné zmáčknutí klávesy Ctrl klikneme na sloupce Flour(Y) a Temp(Y). 

f) Klikneme na ikonu dvouvrstvé Y-osy  Double-Y . 

 

Maskování dat v grafu 
Volba Mask poskytuje další nástroj k vyřazení dat z analýzy. Maskovat lze jednotlivé body či celé skupiny 

bodů. Jakmile jsou data maskována, můžeme měnit jejich barvu, zviditelnit či skrýt maskovaná data, vyměnit 

maskované data za nemaskovaná a povolit či zakázat maskování. 

a) Provedeme View→ Toolbars→zaškrtneme Mask→ Close. 

b) Kliknutím na ikonu Regional Mask Tools  aktivujeme Data Reader (okno grafu musí být přitom 

aktivováno). 
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c) Pohybujeme kurzorem po bodech, pomocí mezerníku zvětšíme průvodce. Klikneme na bod, pak 

mezerníkem zvětšíme průvodce a pomocí šipek se pohybujeme po bodech. 

d) Vybereme bod (např. X=34 a Y=0.59) a označíme ho (změní se jeho barva). Okénko Data Display 

ukazuje souřadnice bodů. Tak odkryjeme například vybočující body, outliery. 

 
e) Pomoci Windows v menu se přepneme do tabulky dat, kde je nyní tento bod (outlier) označen. 

 

f) Klikneme na ikonu Hide/Show Masked Point , čímž nám detekce bodu zmizí. Opětovným 

kliknutím na tuto ikonu se detekce bodu opět objeví. 

 

Lineární proložení grafu u dat FLOUR 
Maskováním nalezeného outlieru vyřazujeme tento vybočující bod z další analýzy lineární regresí. Můžeme 

však vyřadit maskovací proces sloužící především k vyřazování outlierů a analyzovat tak a prokládat všechny 

body souboru. 

 

a) Lineární regrese se zamaskovaným fatálním outlierem: 

Okno grafu je aktivní→ klikneme na jakýkoliv bod, čímž se nám označí všechny body skupiny→vybereme 

Analysis→ Fitting→ Linear Fit → Open dialog→OK a v zobrazeném dialogu Reminder Message vybereme 

No. Body se proložily přímkou a zobrazila se tabulka, kde jsou uvedeny hodnoty parametrů A, B dále hodnoty 

proložení R atd. Tabulka se, kromě toho, že je vložena v grafu, otevřela také jako samostatné okno Table1. 
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b) Lineární regrese bez maskování fatálního outlieru: 

Nejprve zakážeme maskování pomocí ikony , čímž se zamaskovaná data zbarví stejně jako ostatní body. 

Poté opět vybereme Analysis→ Fitting→ Linear Fit → Last used. Funkčnost maskování si ověříme 

porovnáním výsledků obou proložení. 

 
 

TVORBA VÍCEVRSTVÉHO GRAFU 
 

Vrstva je základní stavební jednotkou grafů. Obsahuje jeden soubor řídících os. Vrstvu může tvořit 1 až 4 osy 

(X dole i nahoře a Y vlevo i vpravo). Vrstva obsahuje také textové popisy os, vykreslené objekty, grafy bodů a 

toto vše může být zobrazeno nebo skryto. Okno grafu může obsahovat minimálně jednu a maximálně 80 

vrstev. 

 

Pojetí vrstev v grafu 
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Existuje jediná a jenom jediná aktivní vrstva grafu. Tato aktivní vrstva je jediná, kterou lze pomocí panelů a 

příkazů upravovat a se kterou lze pracovat. Data a objekty mohou být přidávány pouze do aktivní vrstvy. Okno 

grafu má jednu či více vrstvových ikon (pokud ale nejsou uživatelem záměrně skryty), a to jednu ikonu 

s číslem pro každou vrstvu. Aktivní vrstvu poznáme podle prosvícené číselné ikony. 

 

 Ke skrytí ikon vrstev provedeme příkaz View→ Show→ Layer Icons. 

 K prosvícení osy v aktivní vrstvě provedeme View→ Show→ Active Layer Indicator. 

 
 

 Aktivovat vrstvu lze několika způsoby: 

 jedním kliknutím na ikonu vrstvy v rohu grafu. 

 jedním kliknutím na rámeček vrstvy. 

 kliknutím na libovolný objekt, patřící do této vrstvy. 

 

Otevření souboru projektu 

Otevření souboru projektu provedeme kliknutím na ikonu → a pak vybereme Tutorial_3.opj→ Open. 

 

Šablony pro tvorbu vícevrstvých grafů 
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Origin obsahuje bezpočet užitečných a vestavěných šablon pro tvorbu vícevrstvých grafů. Využití těchto 

šablon je proces o dvou krocích, ve kterém: 1) vybereme data, 2) klikneme na ikonu k zobrazení dat do 

vícevrstvého grafu v okně grafu. 

 

Šablona Double-Y je ideální k zobrazení dat, které se skládají ze dvou či více závisle proměnných a jedné 

nezávisle proměnné.  

K dispozici máme množství šablon  

 

Horizontálně 2 panely 

 Nejprve pomocí RestoreUp ikony otevřeme dole uložené okno Layers , které 

má při uložení tuto podobu. 

 Potom pomoci klávesy Ctrl vybereme začerněním data Potential1(Y) a Pressure1(Y). 

 Nakonec klikneme na ikonu Horizontal 2 Panel  a dostaneme následující graf. 
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Vertikálně 2 panely 

 Nejprve pomocí RestoreUp ikony otevřeme okno Layers . 

 Pak vybereme data Potential1(Y) a Pressure1(Y). 

 Nakonec klikneme na ikonu Vertical 2 Panel  a dostaneme graf. 

 
 

Šablona 4 panely 
 Pro tvorbu tohoto grafu je nejprve nutné vybrat také druhou osu X. To provedeme tak, že v oknu Layers 

klikneme pravou myší na sloupec Trial2(Y)→ Set As→ X. Tím se z toho sloupce stane druhá osa (X2) a 

sloupce za ním jsou pak označeny (Y2) 

 Označíme všechna data v tabulce (šipka do levého horního rohu) a klikneme na ikonu  
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Tvorba vlastní šablony vícevrstvého grafu 
Můžeme si vytvořit vlastní šablonu nebo můžeme využít Originovskou šablonu jako startovní bod pro naši 

vlastní šablonu. 

 Nejprve otevřeme projekt Tutorial_3.opj. 

 Pomocí RestoreUp ikony otevřeme okno Layers→ označíme sloupec Potencial1(Y)→ klikneme na ikonu 

Line  v menu Plot. 

 
 

 Vybereme z menu Graph→ Layer Management (k dispozici pouze pokud je okno grafu aktivní). 

 
 

 V záložce Add vybereme Type Right-Y, Link To necháme číslo 1 a Apply, čímž se nám do grafu přidá 

druhá osa Y. Osa X v 2. vrstvě je spojena s osou X v 1. vrstvě, tzn., pokud změníme osu X ve vrstvě 1, změní 

se automaticky i ve vrstvě 2. Lze také přidat pomocí ikony  na Toolbaru Graph. 

 Provedeme nyní dvojklik na ikonu 2.vrstvy→ otevře se dialog Plot Details: Configure Data Plots in 

Layer.  

 V první části vybereme Workbook LAYERS, v druhé části zvolíme za X Trial1 a za Y Pressure1 a 

potvrdíme pomocí Add. Data se nám přidají do třetí části do RightY. 

 Zaškrtneme Rescale a nakonec potvrdíme pomocí OK. 
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Uspořádání vrstev v okně grafu 
Nyní přidáme další vrstvu tak, aby vznikl graf o dvou panelech osy Y, na levé straně Y a na pravé straně Y. 

 Graph→ Layer Management→ záložka Arrange→ do Number of Rows napíšeme 2→ Number of 

Columns je 1→ Apply 
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 V záložce Add vybereme opět Type Right-Y, ale tentokrát v Link dáme číslo 3, aby se nám tyto vrstvy 

„spojili“→Apply 

 

 Vpravo zkontrolujeme, zda vrstvy byly vytvořeny správně a potvrdíme pomocí OK. Pokud jsme 

některou vrstvu vytvořili špatně, označíme jí vlevo a pravým kliknutím vybereme Delete Layer. 
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Vložení dat do nové vrstvy 
K vložení dat do 3. a 4. vrstvy použijeme stejné dialogové okno Plot Details: Configure Data Plots in Layer 

jako v předchozím případě (dvojklik na ikonu 3.vrstvy→ otevře se dialog).  

 V první části vybereme Workbook LAYERS, v druhé části zvolíme za X Trial2 a za Y Potential2 a 

potvrdíme pomocí Add. Data se nám přidají do třetí části do Layer3. 

 Ve třetí části dialogu klikneme na Right-Y pod Layer3, čímž můžeme rovnou přidat data do vrstvy 4 

 V první části opět vybereme Workbook LAYERS, v druhé části zvolíme za X Trial2 a za Y Pressure2 a 

potvrdíme pomocí Add. Data se nám přidají do třetí části do Right-Y. 

 Po „rozklikntí“ všech vrstev dostaneme toto: 

 

 U všech vrstev zvolí Rescale a ukončíme pomocí OK 
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Propojování os 
Osy lze propojit tak, že změníme osu mateřskou a změní se tím také osa dceřiná. Osy mohou být propojeny 

rozměrově, hodnotami osy nebo obojí. 

 Dvojklik na bílé pozadí nad grafem→ otevře se dialog Plot Detail 

 V levé části klikneme na + a zvolíme si Layer3 

 V záložce Link Axes Scales vybereme Link To a Layer1. 

 V části Link Axes in Child Layer to Parent v části X-Axis Link vybereme Straight (1 to1)→ OK. 

 Nyní jsou obě osy X stejného rozpětí se stejnými kroky. Jakmile změníme např. rozpětí u osy ve vrstvě 1, 

změní se automaticky i rozpětí osy ve vrstvě 3. 

 

Přizpůsobení legendy 
Legenda je vždy automaticky tvořena s grafem. Pokud přidáváme do grafu nová data, legenda se sama 

nedoplní. Jinak lze legendu obnovit pomocí ikony . Legendu si můžeme individuálně přizpůsobit pomocí 

pravého tlačítka myši na legendě→ Properties→ do místa pro text můžete napsat cokoliv. Pokud máme více 

vrstev a v každé vrstvě jiná data nebo více čar v grafu a potřebujeme barevně označené čáry před textem, stačí 

před text napsat \l (1.1) pro první čáru, (2.1) pro druhou… 

 

Uložení grafu jako šablony 
Šablona si ponechává informace o tom, jak by měla být data zobrazena, ale samotná data nejsou šablonou 

uložena. Když dokončený graf uložíme jako šablonu, můžeme tuto šablonu užít v případě, že bychom 

potřebovali vytvořit podobný graf. Stačí pak pouze vybrat data z pracovního sešitu a pomocí volby Tools→ 

Template Library→ vybrat námi uloženou šablonu. 

 

Náš vytvořený graf uložíme jako šablonu volbou File→ Save Template As → pojmenujeme (Multilayer)→ 

v Template Category vybereme User Defined→ Save. 
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ŠABLONY 
 

Šablony jsou dceřiná okna, která byla uložena jako soubory se vzhledovými vlastnostmi nastavenými na 

předdefinované hodnoty. Všechny grafy v Originu jsou tvořeny načtením příslušné šablony pro daný typ 

grafu. Každé ze tří hlavních dceřiných oken má svoji příponu, která je charakteristicky spojena s šablonou: 

Pracovní list (worksheet) .OTW 

Graf .OTP 

Matice .OTM 

Tyto tři druhy souborů neobsahují žádná data. Nicméně, v případě šablony grafu (*.OTP soubory) musíme 

vynést nějaká data, abychom vůbec mohli uložit graf, který jsme si takto nadefinovali. 

 

Tvorba šablony grafu 
Většina grafů v Originu je tvořena pomocí vložení vlastních dat do předuložených šablon grafů. Většina 

vizuálních prvků může být uložena jako šablona a aplikována na nová data. Nesmíme zapomenout, že když 

uložíme okno grafu vyneseného z menu nebo z ikony užitím existujícího názvu šablony, pak všechny grafy 

vytvořené pomocí tohoto menu budou mít nový vzhled. Samozřejmě můžeme uložit šablonu grafu pod 

vlastním jménem, a to pomocí Plot→ Template Library. 

 Otevřeme nový pracovní list → naimportujeme ASCII soubor Group.dat ze složky Tutorial. 

 Označíme sloupce B(Y) až D(Y)→ z menu vybereme Plot→ Line+Symbol. 

 Provedeme Format→ Plot→ Plot Details nebo dvojklik do plochy grafu. 

 Rozbalíme nabídku Layer1 a vybereme Group:A(X),B(Y) 

 V záložce Symbol→ Symbol Color místo Automatic  vybereme Individual Color→ Red. 

 V Interior zvolíme Open→ Fill Color→ Individual→ LT Yellow. 

 

 
 

 V záložce Group klikneme na „duhu“ v řádku Line Color→ klikneme na tlačítko → klikneme pravou 

myší na kteroukoliv barvu→ Load→ Color List RGB→ objeví se jen 3 barvy→ pravou myší na Red→ 

delete→ OK. 

 Klikneme na symboly v řádku Symbol Type→ objeví se tlačítko → klikneme pravou myší na 

kterýkoliv symbol→ Load→ Symbol List Triangles→ pravou myší na → Delete a → Delete→ OK.  
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 Pravou myší klikneme kamkoliv do sloupce Increment nebo Details a zvolíme Nested. 

 

 
 

 Získáme graf, který bude vypadat takto (nebo velmi podobně, barva a symboly nemusí odpovídat přesně): 

 

 

 Šablonu uložíme File→ Save Template As→ Category zvolíme User Defined, v Template Name 

napíšeme Tutorial.OTP→ OK 

 Vrátíme se do původního listu a přidáme další sloupec Column→ Add New Columns→ do sloupce E(Y) 

napíšeme čísla 4,8,12,16,20,24. 

 Označíme sloupce B(Y) až E(Y)→ Plot→ Template library→ v tabulce Category vybereme User Defined 

a Tutorial→ Plot. 
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Užívání šablon 
Existují tři různé způsoby pro zvolení šablon: 

 Template Library (šablony grafů). 

 File→ New…menu (libovolný typ šablony). 

 Pomocí LabTalk nebo programového kódu OriginC (libovolný typ šablony). 

 

TÉMATA 
 

Témata poskytují metodu k aplikování sestavy předdefinovaných formátů na objekt, data, graf, jedno grafické 

okno nebo na soubor grafických oken. Tím se odlišují od šablon, které mají vzhled grafu uložený do souboru, 

který musí být nahrán uživatelem a který obsahuje styl grafu. Pomocí témat můžeme kopírovat prvky stylu, a 

to buď jako celek nebo po částech z jednoho existujícího okna a aplikovat je na okno jiné. Pouze ty prvky, 

které jsou definované tématem lze aplikovat na cílové okno.  

Existuje řada předdefinovaných témat, která můžeme dále upravovat nebo si můžeme vytvořit nové téma. 

Můžeme také určit System Theme, které bude užito pro tvorbu grafů tak, aby odpovídalo většinou vlastností. 

Skupina Incremental Lists podskupina Theme nám umožní nadefinovat seznam vhodných vlastností jako 

například barva nebo výplň vzoru, a obsahuje seznam prvků aplikovatelných buď v Nested (vložený) nebo 

v Concerted (soustředěný) přídavek do vícevrstvého grafu. 

 

Tvorba a aplikace témat 
Můžeme vytvořit nové téma kopírováním existujícího grafu, kopírováním tématu, přidáním nového tématu a 

tvorbou jednoho prvku v čase. Téma se bude skládat z několika nebo více prvků grafické vrstvy, jež jsme 

vybrali. K tomu nám poslouží několik dialogových oken. 

Kliknutím pravým tlačítkem myši do místa grafu se nabízí dvě možnosti k vytvoření tématu z grafu: 

 Pomocí volby Copy Format se aktuální téma uloží do paměti 
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 Pomocí volby Save Theme As uložíme pak téma do souboru: 

 

 
 

 

Kopírování tématu z existujícího grafu 
 klikneme na File→Open→Plots.opj  

 Naimportujeme pomocí ikony  data Tutorial/group.dat. 

 Označíme sloupce B,C a D a vytvoříme Scatter graf pomocí ikony  
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 Necháme okno našeho grafu sloupců B, C a D zmenšené a posuneme jej stranou tak, abychom současně 

viděli i okno s diagramem pod názvem MixedScale.  

 V okně MixedScale klikneme pravým tlačítkem vlevo vedle osy Y→ vybereme Copy Format→ All. 

 V okně Graph1 klikneme pravým tlačítkem vlevo vedle osy Y→ vybereme Paste Format. 

 Tím jsme překopírovali formát grafu, ale vybraná data nejsou zde přitom ve vhodném rozsahu: 

 

 Vybereme z menu Edit→ Undo nebo Ctrl+Z tím vrátíme vše zpět. 

 Opět v okně Mixed Scale klikneme pravým tlačítkem→ vybereme Copy Format→ All Styles Formats 

(ten nevybírá Dimension a Scales). 

 Opět v okně Graph 1 pravým tlačítkem vybereme Paste Format. 

 
 

 Opět klikneme pravým tlačítkem vlevo od osy→ Save Format As Theme→ pojmenujeme Before Edit, 

zvolíme ve Formats to Save okénko All→ OK, a téma je tím uloženo do souboru Originu a je nyní připraveno 

k užití. 

 

Galerie Theme Gallery a systémová témata 
 Vybereme Tools→ Theme Organizer nebo pomocí F7. 
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 V tomto dialogovém okně můžeme téma duplikovat, mazat nebo upravovat, a to pravým tlačítkem na 

název tématu. 

 Odškrtnutím Exclude Increment Lists zobrazí Group Incremental Lists (témata, která lze aplikovat 

pouze na skupinové soubory dat, které mají jeden z prvků nastavený jako Incremental). 

 Klikneme pravým tlačítkem na Before Edit téma→ vybereme Duplicate. 

 Klikneme pravým tlačítkem na kopii Before Edit→ Edit→u Page-Background-BaseColor změníme barvu 

na žlutou, a to kliknutím na rámeček barvy. 

 

 
 

  U Global-ColorList klikneme na barevné spektrum, pomocí tlačítka  otevřeme další dialog→ 

klikneme pravým tlačítkem na jakoukoliv barvu→ Load→ Color Lists RGB.OTH→ OK→OK. 

 V dialogovém okně Theme Gallery dvojklikem na BeforeEdit→ přejmenujeme na After Edit→ Close. 

 

Užití tématu 

 Otevřeme okno pojmenované Group→ označíme sloupce B(Y), C(Y) a D(Y)→ ikona . 

 Pomocí F7 nebo Format→ Theme Gallery vybereme téma After Edit→ Aply Now, poté vybereme téma 

Ticks All In→ Aply now. 

 Dvojklikem v oblasti grafu otevřeme dialog Plot Details→ označíme Layer1 a klikneme na 

Group:A(X),B(Y)→ v záložce Group vybereme Border Color a Fill Color v části Incrrement u obou změníme 

None na By One→OK. 
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3D-POVRCHOVÉ  a  OBRYSOVÉ GRAFY 
 

V Originu existují dvě primární struktury dat: pracovní list a matice. Data uložená v pracovním sešitě mohou 

být užita pro tvorbu jakéhokoliv 2D-grafu a vybraných 3D-grafů. Pokud ale chceme vytvořit 3D-povrchový 

nebo obrysový graf, musíme mít data uložena v matici. Origin proto nabízí metodu pro konverzi pracovního 

sešitu na matici a zpět. 

 

Úvod do matic v Originu 
Matice mají číslované sloupce lineárně pro osu X a řádky rovněž lineárně pro osu Y. Hodnoty X a Y v řádcích 

a sloupcích matice si můžeme zobrazit pomocí View→ Show X/Y. Každá buňka matice představuje hodnotu 

osy z, která je vynesena pro souřadnice X (určené sloupcem) a Y (určené řádkem). 

 Otevřeme novou matici pomocí ikony New Matrix  a vytvoří se prázdná matice. 

 Vybereme Matrix→ Set Dimension/Labels, do Columns x Rows napíšeme 21. 

 Do tabulky Coordinates napíšeme pro X i Y u First -10 a Last 10→ OK. Ověříme si nyní, zda matice 

obsahuje 21 sloupců a 21 řádků. 
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 Z menu vybereme View→ Show X/Y. 

 Maximalizujeme okno a zkontrolujeme, zda je rozmezí X i Y od -10 do 10. 

 Pro nastavení hodnot Z vybereme Matrix→Set Values. 

 Do textového pole napíšeme x→ OK→ každá buňka je vyplněna číslem dle hodnot x. 

 Opět vybereme Matrix→ Set Values a do textového pole napíšeme cos(x)+sin(y)→ OK. 

 K vytvoření obrysového grafu z těchto dat zvolíme Plot→ Contour Plot→ Color Fill. 

 

 

Konverze pracovního sešitu na matici 
Data z pracovního listu nebo tabulky Excelu je nutné transformovat na matici před tvorbou 3D povrchového 

nebo obrysového grafu. 

 Z menu vybereme File→ New→ New Project→ Import→ Simple Single ASCII→ otevřeme 

Tutorial_5.dat. 

 

 Označíme sloupec C(Y) → pravým tlačítkem→ Set As→ Z. 

 

Důležitým krokem je nyní výběr správné metody konverze, protože v nabídce je několik metod: Direct, 

Expand Columns, 2D binning, regular XYZ, random XYZ.  Zvolená metoda totiž závisí na povaze dat 

v pracovním listu dle následujícího popisu: 
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1) Direct Conversion:  Běžný formát xyz-ových dat je uspořádán následovně: hodnoty X jsou ve sloupci 

nejvíce vlevo, hodnoty Y jsou v prvním řádku a hodnoty Z jsou ve sloupci 2-N a řádku 2-M. Pokud jsou naše 

data v pracovním sešitě takto uspořádána, můžete užít přímé konverze. 

2) Expand Columns: Existují případy, kdy obrazový editor, který byl použit pro tvorbu ASCII souboru, má 

limit pro maximální počet znaků v jednom řádku. Tento limit může být dokonce nižší než počet sloupců 

v požadované matici. Výměnou za to může být jeden řádek matice dat uložených v několika řádcích souboru 

ASCII. Po importování takovýchto dat do pracovního listu zkopíruje metoda Expand Rows vámi zadaný 

počet řádků pracovního sešitu, které budou tvořit první řádek matice. Origin opakuje tento postup k převedení 

všech řádků v pracovním sešitě. 

3) 2D Binnig: Tato metoda uloží data XY tak, že vytvoří frekvenci výpočtu datových bodů bez udání 

rozsahu XY a uloží vypočtené hodnoty jako hodnoty Z do matice. 

4) Regular XYZ: Abychom mohli užít tuto metodu, musí (a) každá hodnota X mít stejný počet y-ových 

hodnot a každé Y musí mít stejný počet x- ových hodnot a (b) hodnoty dat X a Y si musí být rovné. 

5) Sparse XYZ: Tato metoda konvertuje „pravidelná“ data XYZ na matici pomocí předpokladu chybějících 

hodnot páru dat X,Y. 

6) Random XYZ: Pokud nejsou data podle žádného z předchozích typů, lze je označit za data náhodná. 

Proces pro konverzi náhodných XYZ dat do matice se nazývá gridding. Origin nabízí několik metod 

griddování, zahrnující metodu Renka and Cline a modifikaci Shepardovy metody. 

Nejvíce asi budeme používat pro konverzi dat do matice metody Regular XYZ a Random XYZ. Existuje 

jednoduchý test k určení nejvhodnější metody pro vaše data. Zahrnuje vybrání pouze x- ových  a y- ových 

sloupců xyz- ového pracovního listu a vynesení těchto dat do bodového grafu  (Scatter Plot). Pokud se 

výsledný graf podobá „půdorysu sadu“ (každý bod představuje strom), můžeme říci, že se jedná o Regular 

XYZ. Pokud výsledný graf nejeví takovouto uspořádanost, jedná se o data Random XYZ. 

 

 Aktivujeme okno Tutorial 5→ vybereme sloupce X a Y→ vytvoříme Scatter Graph .  

 

 Je zřejmé, že naše data nejsou pravidelně rozmístěná v prostoru, takže budeme tato data převádět na 

matici pomocí Random XYZ konverze. 

 Pro převedení pracovního sešitu na matici vybereme sloupec C(Z)→ Worksheet→ Convert to Matrix→ 

XYZ Gridding→ v části Gridding Settings vybereme metodu Random (Renka Cline)→ v Advanced - 

Preview Plot Type zvolíme 3D Wire Frame→ OK 
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 Můžeme měnit metody griddování, zobrazí se nový graf, abychom si mohli ověřit, která metoda nejlépe 

odpovídá našim datům. 

 

Zobrazování a mód rychlosti 
 Aktivujeme okno s maticí Renka- Cline 

 

 Vybereme Plot→ 3D Surface → Color Map Surface→ objeví se dialog, který upozorňuje, že váš graf 

bude zobrazen pomocí Speed Mode → OK 

 Rychlostní mód může být užitečný pro rychlé překreslování grafu, jelikož zobrazuje pouze redukovaný 

počet bodů. Hlavně pokud se jedná o velkou matici dat, může nám tento mód ušetřit čas. Speed mode snižuje 

počet vykreslených bodů systematickým odstraněním každého n- tého bodu z matice. Speed Mode lze uplatnit 

ve 3 režimech- Video Display, Clipboard Images and Graphic Export files a Printout.  
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 Z menu vybereme Format→ Layer→otevře se dialogové okno Plot Details 

 Vybereme záložku Size/Speed 

 V tabulce Speed Mode, Skip Points if needed odškrtneme volbu Matrix data, maximum points per 

dimension→ OK. 

 

 Pamatujte, že vzhled grafu se dá měnit. Speed mode je automaticky nataven na 15 sloupců a 15 řádků, 

ale odškrtnutím volby Matrix data, maximum points per dimension nám umožní vynést do grafu všech 20 

sloupců a 20 řádků. 

 

Přizpůsobení grafu 
Origin umožňuje plnou kontrolu nad výběrem barevného spektra. Barvy si můžete upravit v dialogovém okně 

Plot Details po vybrání Layer1→ matrix→ v záložce Color Map. Zde můžeme volit barvy pro jednotlivé 

vrstvy a také rozmezí vrstev. Barvy můžeme volit buď jednotlivě kliknutím na barvu, kterou chceme nahradit 

a výběrem nové barvy nebo můžeme jen upravit rozmezí barev kliknutím dvakrát na nadpis Fill a určením 

barvy From a To. Rozmezí můžeme opět upravovat manuálně výběrem jednotlivých čísel nebo pomocí 

dvojkliku na nadpis Level a udáním minima a maxima. Můžeme zde také přidat či ubrat počet „pater“ (ševelů) 

pomocí zadání hodnoty do Num. Of Levels. 



ZÁKLADNÍ KURZ PROGRAMU ORIGIN 8.5  ING. ZUZANA FERENČÍKOVÁ 

 

52 
 

Pokud zadáme jako výchozí barvu Red a konečnou barvu Green (klikneme dvakrát na Fill a zadáme From 

Red a To Green) a počet pater zvolíme 12 (dvakrát klikneme na Level a do Num. Of levels napíšeme 12), 

pak náš graf bude vypadat takto: 

 
Lze také vybrat pouze určitou hodnotu, kterou chcete zvýraznit: Dvakrát klikneme na graf→Plot Details→ 

vybereme Layer1→ Matrix→ záložka Color Map→ vybereme barvu, která oodpovídá hodnotě 1.76E-4 a 

změní ji na Dark Grey→ OK. 

 
 

Přidání kontur ke grafu Color Map Surface 
 Klikneme dvakrát na plochu grafu→ Plot Details→ Vybereme Layer1→ [MBook2]MSheet1!...→ 

zvolíme záložku Surface/Projections→ v řádku Fill Color zaškrtneme navíc volbu Bottom Contour→ OK 
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Změna rozsahu osy Z 
 Vybereme z menu Format→ Axes→ Z Axis→ v záložce Scale do políčka From napíšeme -1E-4→ OK. 

 
 

Změna perspektivy grafu 
Jakmile vytvoříme nový 3D graf, zobrazí se automaticky i nástrojová lišta 3D Rotation.  

 
Tato lišta nabízí tlačítka pro kontrolu perspektivy 3D grafu. Rotací 3D grafu můžeme dosáhnout lepšího 

zobrazení našich dat. 

 Na nástrojové liště 3D Rotation klikneme na Tilt Up .  

 Na nástrojové liště 3D Rotation klikneme na Rotate Clockwise .  
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PROKLÁDÁNÍ DAT KŘIVKOU 

NELINEÁRNÍ FUNKCE 
 

Origin nabízí několik metod nelineární regrese k prokládání dat křivkou. Tyto metody se liší rychlostí, 

komplexností, takže si můžeme vybrat metodu, která proloží naše data nejvhodněji. 

 

Prokládání pomocí nabídky menu 
Origin nabízí několik funkcí přímo v nabídce Analysis→ Fitting v menu. K vytvoření proložení je nutné 

zkontrolovat, že jsou vaše data v grafu aktivní, poté stačí vybrat vhodnou metodu z menu Analysis. Po vybrání 

metody Origin zobrazí křivku prokládající body grafu a zároveň zobrazí tabulku s výsledky. 

 

 Nejprve otevřeme nový projekt pomocí ikony  

 Ve složce Tutorial vybereme soubor Fitexmp1.opj. Otevře se nám okno s daty a zároveň i okno grafu. 
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 Aktivujeme okno grafu→ z menu vybereme Analysis→ Fitting→ Exponential Fit→ v rozevíracím 

seznamu Function vybereme ExpDec1 a pomocí ikony  spustíme fitování→Done 

 

 Origin vygeneruje nejlepší model proložení, poté data proloží křivkou a zobrazí výsledkový dialog 

s informacemi o datech a o proložení 

 

Prokládání pomocí Fitovacího dialogu 

 


